Начало работы с SimInTech

Перед тем, как приступать к выполнению упражнений рассмотрим среду динамического моделирования SimInTech и базовые понятия, необходимые для дальнейшей работы с ней.

Запуск SimInTech осуществляется одним из двух способов:

  1. С помощью ярлыка, который появляется на рабочем столе после установки SimInTech. Для запуска нужно совершить двойной клик левой кнопкой мыши по ярлыку;
  2. В зависимости от версии операционной системы:
    • для Windows XP, 7, 10 – с помощью стартового меню «Пуск»;
    • для Windows 8, 8.1 – с помощью выбора соответствующего ярлыка на экране приложений.
После запуска приложения на экране появится главное окно среды динамического моделирования SimInTech (Рисунок 1).

Рисунок 1. Главное Окно SimInTech

Данное окно условно можно поделить на три области (сверху вниз):

Рассмотрим, за что отвечает каждая из областей подробнее.

Главное меню позволяет производить настройку программы под конкретные нужды пользователя, управлять созданием, редактированием и расчетом сформированных схем, содержит инструменты работы с базой данных, настройки визуального вида схемного окна и пр.

Панель кнопок является настраиваемой областью с набором кнопок, отвечающих за некоторые часто используемые команды. Данная панель служит для ускорения доступа к этим командам. Содержащиеся на данной панели кнопки разбиты по группам в соответствии с выполняемыми функциями.

Отображение групп кнопок пользователь может изменять по своему усмотрению. Для того, чтобы отобразить или скрыть группы кнопок, необходимо кликом правой кнопки мыши по области кнопок вызвать выпадающее меню, в котором затем нужно активировать или деактивировать путем установки/снятия галочек видимость нужных пользователю групп кнопок в главном окне (Рисунок 2).

Рисунок 2. Контекстное меню настройки видимости групп кнопок в главном окне SimInTech

Палитра блоков – это набор блоков, который используется для формирования расчетных схем в текущем активном шаблоне. Создание расчетных моделей с использованием блоков – один из способов разработки расчетных моделей в среде SimInTech.

Набор блоков в Палитре блоков изменяется в зависимости от выбранного типа решателя схемы, то есть когда выбран решатель «Автоматика», отображается палитра блоков для реализации общих схем, а когда выбран решатель «Теплогидравлика», отображается набор блоков для реализации теплогидравлических моделей.

Все новые проекты в SimInTech создаются на основе шаблонов. Шаблон представляет собой расчетную схему, которая наиболее подходит для решения определенного круга инженерных задач, и, как правило, содержит заранее определенный решатель.

В зависимости от установленной конфигурации SimInTech может отображаться разный набор шаблонов. В базовой версии SimInTech доступны следующие типы шаблонов:

Создание новой расчетной схемы можно осуществить двумя способами:

  1. Выбрать в главном меню пункт «Файл» - «Новый проект» и из выпадающего списка выбрать нужный шаблон расчетной схемы;
  2. Воспользоваться кнопкой «Новый проект» на панели кнопок (данная кнопка находится в группе «Файл», поэтому если она не отображена в основном окне, то необходимо кликом правой кнопки мыши по главному окну среды SimInTech вызвать меню настройки видимости групп и активировать для отображения группу кнопок «Файл»), после чего в выпадающем списке выбрать нужный шаблон.

После выполнения одного из вышеуказанных способов на экране появится окно нового проекта.

Для данного окна полностью применим функционал стандартных методов операционной системы при работе с окнами: можно изменять визуальные размеры окна, его расположение на экране, сворачивать и разворачивать окно на весь экран и пр. При сохранении проекта сохраняются и визуальные настройки окна, например такие, как размеры окна.

При открытии окна, когда уже ранее было открыто несколько окон других проектов, данное окно будет активным для редактирования, остальные же окна автоматически перейдут в пассивный режим. Перевести их в активный режим можно либо одиночным кликом левой кнопки мыши по области окна, либо вызвав данное окно из строки состояния операционной системы, либо в главном окне SimInTech перейти в меню «Окно», в котором выбрать нужное окно проекта.

Окно проекта является типовым, и строение его одинаково для всех шаблонов, входящих в SimInTech.

Рассмотрим подробнее области данного окна (Рисунок 3):

Рисунок 3. Области схемного окна SimInTech (на примере шаблона автоматики)

Меню окна проекта отвечает за основные функции работы со схемой, такие как создание новой схемы, сохранение схемы, открытие ранее созданных схем, вызов базы данных, предоставление доступа к справочным материалам, а также настройку визуального отображения схемы.

Панель кнопок проекта представляет собой набор объектов для настройки и управления расчетной схемой, которые делятся на две группы: «Слои» и «Расчет» (Рисунок 4). Данные группы можно отобразить или скрыть на схемном окне. Для этого можно либо пройти в меню «Вид» - «Панель инструментов» и активировать/деактивировать соответствующие пункты, либо необходимо кликом правой кнопки мыши по области кнопок вызвать контекстное меню, в котором можно сделать то же самое.

Рисунок 4. Панели кнопок схемного окна SimInTech

В первой группе содержатся следующие объекты (Рисунок 4):

Во второй группе содержатся кнопки управления расчетом (Рисунок 4):

В рабочей области окна проекта при помощи блоков, находящихся в палитре блоков, можно создавать и редактировать ранее созданные расчетные модели, создавать собственные блоки и многое другое.

Поместить на схемное окно проекта расчетный блок просто. Для этого необходимо выполнить следующие действия:

  1. Выбрать вкладку в Палитре блоков, на которой находится нужный блок. Блоки в Палитре блоков скомпонованы по вкладкам с учетом общих признаков (например, вкладка «Операторы» общетехнической библиотеки блоков содержит блоки, отвечающие за различные математические действия: сложение, вычитание, умножение, деление и пр.)
  2. Одинарным кликом левой кнопки мыши выбрать блок, который необходимо установить в рабочей области окна проекта: как только блок будет выбран, появится его подсветка в Палитре блоков. При появлении курсора мыши в пределах рабочей области, вид курсора мыши изменится: появится выбранный блок, а вместо курсора появится крестообразный указатель места установки для этого блока.
  3. Выбрать место установки блока в рабочей области окна проекта.
  4. Одинарным кликом левой кнопки мыши установить блок в рабочей области окна проекта.

Строка отображения расчетной информации позволяет контролировать ход расчетного процесса, а также позволяет оперативно изменять масштаб отображения на схемном окне (для этого нужно совершить одинарный клик левой кнопки мыши на поле «Масштаб», после чего перед пользователем появится окно изменения масштаба для схемного окна (Рисунок 5)), включать и отключать сетку схемного окна одинарным кликом левой кнопки мыши по полю «Сетка», включать и отключать привязку объектов к сетке одинарным кликом левой кнопки мыши по полю «Привязка».

Рисунок 5. Окно «Масштаб», предназначенное для изменения масштаба рабочей области окна проекта

При запуске схемы на расчет в этой области также появляется окно сообщений, в котором отображается диагностическая информация по расчетной схеме: ошибки при задании свойств блоков, предупреждения, связанные с работой блоков и пр.

Задание свойств блока осуществляется при помощи окна свойств блока.

Вызов окна свойств можно осуществить тремя способами:

  1. Выделив блок, одинарным кликом правой кнопки мыши вызвать контекстное меню, в котором выбрать пункт «Свойства объекта» (Рисунок 6);

    Рисунок 6. Пункт «Свойства объекта» в контектсном меню блока

  2. Выделив блок, нажать на панели кнопок кнопку «Свойства» (Рисунок 7);

    Рисунок 7. Главное окно SimInTech с выделенной кнопкой «Свойства» (кнопка выделена рамкой красного цвета)

  3. Совершив двойной клик левой кнопкой мыши по выбранному блоку в режиме редактирования расчетной схемы.
После этого на экране появится окно «Свойства» (Рисунок 8);

Рисунок 8. Окно свойств на примере блока «Синусоидальный сигнал» общетехнической бибилотеки блоков

В окне свойств в зависимости от выбранного блока могут отображаться следующие вкладки:

Наиболее часто в процессе работы с блоком используются вкладки «Свойства», «Параметры» и «Общие».

Среда динамического моделирования SimInTech имеет собственный встроенный скриптовой язык программирования, в котором с помощью операторов и функций можно решить, например, такие задачи, как:

Вызов редактора скриптового языка программирования для текущего активного проекта можно осуществить двумя способами:

  1. Нажав на кнопку «Скрипт» на панели кнопок схемного окна (Рисунок 9);

    Рисунок 9. Вызов окна редактора скриптового языка программирования проекта с помощью панели кнопок схемного окна (кнопка вызова выделена красной рамкой)

  2. Нажав на кнопку «Скрипт» в главном окне программы (Рисунок 10);

    Рисунок 10. Вызов окна редактора скриптового языка программирования проекта с помощью главного окна программы (кнопка вызова выделена красной рамкой)

Для окна проекта доступны два режима отображения рабочей области окна проекта: режим редактирования и режим индикации. Каждый из режимов активирвует свои инструменты при работе с окном проекта в процессе расчета схемы. Если активен режим редактирования, то в процессе расчета модели можно просматривать параметры блоков, изменять их свойства и пр., режим индикации переводит окно проекта в режим мнемосхемы, в котором блоки становятся неактивными для редактирования свойств и просмотра параметров, а у части блоков при совершении определенных действий появляются визуальные окна текущего состояния блока и управления им.

Перевод из одного режима в другой осуществляется с помощью кнопки выбора режима отображения «Индикация/Редактирование» , расположенной на панели инструментов настройки проекта и управления расчетом. Режим, который на данный момент выбран пользователем для окна проекта, отображается в меню окна проекта (Рисунок 11);

Рисунок 11. Окно проекта с выбранным режимом отображения рабочей области окна (в данном случае выбран режим «Редактирование»))