Создание библиотеки блоков

Добавление пользовательских блоков в библиотеку

Создание математической модели в среде SimInTech происходит путем визуальной компоновки схемы, состоящей из блоков расчетных элементов, представляемых на схеме в виде иконок. Каждый расчетный блок скрывает за собой определенный набор математических преобразований исходной величины. Наборы таких блоков, объединенных по определенному признаку, образуют собой так называемые подключаемые библиотеки блоков или, в более широком смысле, библиотеки классов, представляющие собой файлы с расширением .csl. В состав SimInTech уже входит несколько таких библиотек, содержащих базовые блоки для формирования схем автоматики, теплогидравлики и т. д.

Режим работы SimInTech по умолчанию предусматривает, что после запуска программы, автоматически подгружается основная библиотека CommonLib.csl, а также дополнительные библиотеки, указанные на вкладке «Библиотеки блоков» в окне «Параметры», открывающемся по команде Файл → Параметры. В список можно добавлять сторонние библиотеки, созданные для выполнения специальных задач. Изменение списка подгружаемых автоматически библиотек производится с помощью кнопок «Добавить», «Удалить» и «Изменить».

Рисунок 1. Список подгружаемых при старте библиотек блоков

Сразу после запуска SimInTech, до создания или открытия какого-либо файла проекта, на палитре компонентов будут располагаться все блоки, входящие в состав загруженных при старте библиотек. После создания или открытия файла проекта, на палитре компонентов останутся только те блоки, которые можно использовать в том типе проекта, который открыт в настоящее время. Например, при открытии файла теплогидравлического проекта, на палитре компонентов главного окна SimInTech останутся только блоки из библиотеки HS.

Помимо базового режима работы по умолчанию, SimInTech имеет возможность работы в режиме разработчика, который включается установкой галочки напротив пункта главного меню Вид→Режим разработчика.

Рисунок 2. Включение режима разработчика

Кроме прочего, режим разработчика предоставляет расширенный набор функций по работе с библиотеками блоков. В частности, позволяет редактировать содержимое библиотеки и добавлять новые блоки (классы). Для редактирования используется инструмент «Редактирование библиотеки», доступный по команде меню Файл → Редактировать библиотеку.

Рисунок 3. Интерфейс редактора библиотеки

По умолчанию, в редакторе будет открыта основная библиотека ClassLib.csl. Если нужно редактировать другую, то предварительно необходимо, с помощью команды Файл→Загрузить библиотеку, выбрать необходимый .csl-файл. При этом нужно иметь в виду, что выбранная таким образом библиотека, будет считаться основной, вместо ClissLib.csl. В дальнейшем, для получения доступа к блокам библиотеки ClissLib, необходимо либо внести ее в список дополнительно-загружаемых библиотек (Рисунок 1), либо выбрать ее с помощью команды Файл→Загрузить библиотеку, сделав тем самым основной.

В нижней части окна редактора библиотеки находятся кнопки для открытие другого .csl файла, для дополнение текущей библиотеки другим .csl файлом, для сохранения текущей библиотеки в файл и для очищения текущей библиотеки блоков. Основной интерфейс окна редактирования библиотеки состоит из трех вкладок:

Остановимся подробнее на вкладке «Палитра». В ее составе имеется еще одна одноименная вкладка, на которой расположены 3 поля (Рисунок 3):

Работа с полями на вкладке «Палитра» позволяет упорядочить все блоки библиотеки по выбранным страницам. Вторая вкладка: свойства – позволяет редактировать свойства выбранного класса.