Создание базовых блоков

Описание процесса создания нового функционального блока из графических примитивов и базовых блоков.

При разработке новой библиотеки блоков либо работе с уже существующей библиотекой иногда возникает необходимость создания новых функциональных блоков. Например, в расчетном коде появляется модель объекта, которая не может быть описана ни одним из присутствующих в библиотеке блоков, либо в случае создания с «нуля» новой библиотеки. В таких ситуациях необходим функциональный блок, посредством которого будет обеспечиваться связь расчетного кода и SimInTech для того, чтобы создаваемая пользователем расчетная схема правильно транслировалась в расчетный код. Так же пользователю иногда бывает необходимо сделать блок «под себя» для упрощенного решения какой-то конкретной задачи в рамках пользовательского проекта либо для более простого и визуально понятного построения расчетной схемы. Для этих целей обычно используют блок Субмодель, на основе которого создают новый блок со свойствами и параметрами, а внутрь блока «Субмодель» посещается небольшая часть расчетной схемы. Логично и правильно создавать такие блоки в случае, когда на расчетной схеме выполняются присутствует довольно большое количество мест идентичной топологии, набранных из одинаковых блоков и различающихся лишь параметризацией.

Стоит отметить, что в данном описании процесс интегрирования нового блока с расчетным кодом приводится только со стороны пользователя.

Создание каждого блока проходит следующие этапы:

  1. Определяется содержание блока, его функциональные возможности и особенности (на данном этапе содержание предварительное, в процессе последующей работы с блоком его содержание и возможности могут меняться);
  2. Определяется визуальный вид блока (в том числе будет ли блок анимированным или нет), свойства, служащие для задания расчетных характеристик блока, параметры, служащие для отображения результатов работы блока;
  3. С помощью примитивов либо базовых блоков создается первичный простой блок;
  4. К созданному блоку добавляются свойства и параметры, разрабатываются скрипты различного функционального назначения, связанные с работой блока;
  5. Производится тестирование;
  6. Блок добавляется в библиотеку.

Получение первичного блока в среде SimInTech можно выполнить двумя способами. Рассмотрим их подробнее.

1-ый способ – создание первичного блока с помощью примитивов

  1. На листе проекта из графических примитивов создается начальная «заготовка» нового блока (см. Рисунок 1);

    Рисунок 1. Вид схемы с начальной «заготовкой» из примитивов

  2. Графические примитивы выделяются (см. Рисунок 2);

    Рисунок 2. Вид схемы с начальной «заготовкой» из примитивов

    После выделения примитивов становятся активными функции работы с ними, в том числе и функции сборки из примитивов нового блока.

  3. В главном меню проходим по пути Правка → Собрать в блок (см. Рисунок 3);

    Рисунок 3. Команда «Собрать в блок» в меню «Правка»

  4. Получаем первично-созданный блок, с которым можно продолжать работу (см. Рисунок 4).

    Рисунок 4. Собранный посредством применения команды «Собрать в блок» новый блок

2-ой способ – разработка блока на основе базового простого блока

  1. В главном меню проходим по пути Вставка → Базовые блоки (см. Рисунок 5)

    Рисунок 5. Список базовых блоков

  2. В появившемся меню выбираем необходимый нам тип блока, ставим его на лист проекта и продолжаем работу с ним. Для разработки новых блоков обычно используются «Стандартный блок», «Блок - полилиния», «Субмодель».

Отличия способов создания блоков состоят в том, что при использовании первого способа пользователь получает уже приблизительно оформленный графически блок, а при использовании второго способа изображение блока разрабатывается «с нуля» уже непосредственно в самом блоке. В остальном же способы равноценны и позволяют при дальнейшей проработке блока изменять список свойств, параметров, визуализацию и т.д.