Связь с расчетным кодом "Универсальный механизм"

Импорт модели механики, созданной в программном комплексе "Универсальный механизм" (UM).

Работа моделей механических систем, выполненных в среде "Универсальный механизм" (UM-моделей) в SimInTech поддерживается специальным блоком Связь с расчетным кодом Универсальный механизм (УМ), расположенным на вкладке «Данные» палитры блока. Блок позволяет реализовать режим совместного моделирования (CoSimulation) SimInTech и UM. Этот блок доступен в SimInTech начиная с версии 1.17.9.29.

В общем случае моделирования динамики механических систем с использованием совместного моделирования предполагает выполнение следующих этапов.

Модель механической системы UM, подключаемая в систему управления SimInTech, рассматривается как черный ящик, который по некоторому закону преобразует входные величины в выходные. При включении механической системы в модель системы управления на выходы механической системы назначаются переменные, которые создаются при помощи Мастера переменных в среде UM. Входные величины блока «Универсальный механизм» передаются в UM-модель.

Для реализации управляющих усилий со стороны системы управления в модель механической системы вводятся силы/моменты, значения или характеристики (например, коэффициент жесткости, коэффициент диссипации) которых задаются параметрами модели. Затем с помощью Мастера экспорта среды UM эти параметры связываются с величинами, которые являются входами блока SimInTech.

Для демонстрации совместного моделирования используем пример с моделью перевернутого моятника. Файл проекта находится в папке SimInTech\Demo. Мы не будем подробно разбирать этапы создания модели механической части в среде UM, ограничимся только описанием связи механической части с системой управления SimInTech.

Блок Связь с расчетным кодом Универсальный механизм обеспечивает в данном примере связь модели системы управления с моделью ПК «Универсальный механизм». В данной модели для организации управления перевернутым маятником входной переменной для блока будет величина силы, подаваемой на тележку, а выходной величиной блока будет угол отклонения маятника от вертикали.

Рисунок 1. Система стабилизации перевернутого маятника с механической системой в виде блока связи с кодом «УМ»

Настройки проекта в среде UM

Рассмотрим особенности экспорта механической части из UM. Прежде всего необходимо указать, какие именно входные и выходные величины блока «Связь с расчетным кодом УМ» потребуются для моделирования, сохранить связанные с этим настройки и сгенерировать специальный cosim-файл, который будет управлять блоком.

  1. Запустите программу моделирования UM Simulation.
  2. Загрузите модель \Demo\Интеграция со сторонним ПО\Механика Universal Mechanism\Пример 1.

    Перед выполнением дальнейших действий убедитесь в том, что перевернутый маятник отклонен от вертикали и при необходимости задайте это отклонение.

  3. Выберите пункт меню Анализ | Моделирование…
  4. В появившемся окне Инспектора моделирования объекта перейдите на вкладку Начальные условия | Координаты и убедитесь, что координата 1.2 имеет значение 0.3 (рад), а маятник в анимационном окне отклонен от вертикали.

    Рисунок 2. Задание начального отклонения маятника

  5. Выберите пункт меню Инструменты | Мастер экспорта… Появится окно Мастера экспорта.

    Рисунок 3. Мастер экспорта

    В данном случае нам необходимо назначить одну входную и одну выходную величины. На вход модели перевернутого маятника мы подадим величину усилия на тележку, а в качестве выходной величины назначим угол отклонения маятника от вертикали.

    Для того чтобы добавить новую входную величину для UM-модели необходимо выполнить следующие действия.

  6. Нажмите кнопку + над списком Входные величины. Появится диалоговое окно назначения входных величин блока «Связь с расчетным кодом УМ» идентификаторам UM-модели.
  7. В поле Назначать значение входной величины… выберите идентификатор модели force.
  8. Закройте окно кнопкой OK.

    Для назначения выходных величин модели перевернутого маятника, с помощью Мастера переменных сформируем переменную Угол отклонения маятника от вертикали и назначим ее в качестве выходной величины блока «Связь с расчетным кодом УМ».

  9. Нажмите кнопку + над списком Выходные величины. В списке выходных величин появится одна новая величина.
  10. Запустите Мастер переменных (меню Инструменты | Мастер переменных…).
  11. Перейдите на вкладку Угловые переменные, см. Рисунок 4.
  12. В списке тел слева выберите Pendulum, выключите флажок Использовать ориентацию при нулевых координатах, в поле Исследуемая величина выберите Вект.(ор) поворота, а в поле Компонента выберите X.
  13. Создайте переменную кнопкой . Переменная ang:x(Pendulum) появится в контейнере переменных.

    Рисунок 4. Создание переменной

  14. Перетащите мышкой созданную переменную ang:x(Pendulum) в окно Мастера экспорта… и назначьте ее в качестве выходной величины.

    Выход модели станет помечен зеленой галочкой, что означает, что на данный выход блока «Связь с расчетным кодом УМ» назначена переменная.

    Все необходимые настройки для экспорта UM-модели в SimInTech закончены. Далее сохраним настройки в файл *.cosim.

  15. Сохраните заданную конфигурацию нажав кнопку .

    В появившемся окне диалога сохранения файла необходимо указать в названии файла inv_pend_cosim и сохранить его. Одновременно с созданием файла *.cosim будут сохранены все файлы конфигурации (файл параметров, начальных условий и т.д.), которые будут использоваться «Универсальным механизмом» при работе под управлением SimInTech.

    На этом действия на стороне UM закончены. Переходим к описанию связи на стороне SimInTech.

Создание связи между UM-моделью и SimInTech

Для создания связи между системой управления SimInTech и механической моделью выполните следующие действия.

  1. Запустите SimInTech.
  2. В меню Файл нажмите Открыть… и выберите каталог \Demo\Интеграция со сторонним ПО\Механика Universal Mechanism\Пример 1
  3. Откройте файл pendpid.prt, в котором хранится модель системы управления перевернутым маятником.
  4. Двойным щелчком мыши на блок «Связь с расчетным кодом УМ» вызовите окно свойств этого блока.
  5. В поле Файл модели УМ (input.dat) установите полное имя модели в ПК «Универсальный механизм», включая файл input.dat.
  6. В поле Файл конфигурации (*.cosim) установите полное имя файла конфигурации, включая файл inv_pend_cosim.cosim.
  7. Нажмите OK.

Моделирование движения

Модель подготовлена для дальнейшего анализа. Сейчас мы установим параметры моделирования, а затем запустим совместное моделирование.

  1. В окне модели нажмите на кнопку Параметры расчета.
  2. На вкладке Параметры расчета в поле Минимальный шаг установите 0.00001, в поле Максимальный шаг установите 0.001.

    Рисунок 5. Параметры конфигурации модели

  3. Нажмите OK.

    Для моделирования динамики выполните следующие действия.

  4. Двойным щелчком мыши откройте окна Временной график, в которых будут отображаться угол отклонения маятника от вертикали и величина усилия, подаваемого на тележку.
  5. Кнопкой запустите моделирование.
  6. По истечении времени моделирования вы увидите результаты, приведенные на рисунках (Рисунок 6, Рисунок 7).

    Рисунок 6. График изменения угла отклонения маятника от вертикали

    Рисунок 7. График изменения величины усилия, подаваемого на тележку

Сопутствующие материалы