Руководство по созданию моделей электрических схем

Введение в SimInTech

Концепция создания модели объекта в SimInTech

SimInTech обладает широкими возможностями по организации вычислений, связанных с решением алгебраических и обыкновенных дифференциальных уравнений.

Расчетные математические модели в SimInTech создаются посредством функционально блочного программирования при помощи блоков, которые содержатся в различных библиотеках.

Для создания математической модели SimInTech содержит библиотеки:

  • теплогидравлики/пневматики;
  • электротехники;
  • электрических приводов;
  • силовых гидравлических/пневматических машин;
  • механических взаимодействий;
  • баллистики космических аппаратов;
  • динамики полета летательных аппаратов в атмосфере;
  • и т.д.

В SimInTech возможна разработка как простых моделей, подробно описывающих поведение какой-либо системы (например, RLC-контур с источником питания), так и сложных моделей, которые подробно описывают не только саму систему, но и алгоритмы управления, защиты, интерфейс управления и пр.

Для организации синхронного обмена данными между расчетными схемами используется база данных сигналов – структурированное хранилище переменных, используемых в одном или нескольких проектах, входящих в состав сложной модели.

Концепция применения базы данных сигналов для создания сложных комплексных моделей, представлена на рисунке ниже (Рисунок 1).

Рисунок 1. Концепция построения комплексной модели в SimInTech.

При разработке модели с использованием базы данных сигналов возможно объединение разнородных физических процессов системы в один пакет проектов для комплексного моделирования. Использование базы данных сигналов также позволяет подключать сторонние расчетные коды, наиболее полно описывающие специфические физические процессы. Использование такого способа моделирования также позволяет распределить вычисления между ядрами процессора или самостоятельными вычислительными узлами сети в совместной работе нескольких отделов или человек над одним комплексным проектом.

При помощи базы данных сигналов, блоков протоколов обмена (таких, например, как UDP, Modbus, TCP) и устройств ЦАП/АЦП также можно обеспечить подключение реальной аппаратуры управления к математической модели для последующего тестирования и отладки.

Начало работы с SimInTech

Перед тем, как приступать к выполнению упражнений рассмотрим интерфейс SimInTech и базовые понятия, необходимые для дальнейшей работы с ним.

Запуск SimInTech осуществляется одним из двух способов:

  1. С помощью ярлыка, который появляется на рабочем столе после установки SimInTech. Для запуска нужно совершить двойное нажатие левой кнопкой мыши по ярлыку.
  2. В зависимости от версии операционной системы:
    • для Windows XP, 7, 10 – с помощью стартового меню «Пуск»;
    • для Windows 8, 8.1 – с помощью выбора соответствующего ярлыка на экране приложений.

После запуска приложения на экране появится главное окно SimInTech (Рисунок 2).

Рисунок 2. Главное окно SimInTech.

Данное окно условно можно поделить на три области (сверху вниз):

  • 1 область – Меню главного окна - позволяет производить настройку программы под конкретные нужды пользователя, управлять созданием, редактированием и расчетом сформированных схем, содержит инструменты работы с базой данных, настройки визуального вида схемного окна и пр..
  • 2 область – Панель кнопок - настраиваемая область с набором кнопок, отвечающих за некоторые часто используемые команды. Данная панель служит для ускорения доступа к этим командам. Содержащиеся на данной панели кнопки разбиты по группам в соответствии с выполняемыми функциями.
  • 3 область – Палитра блоков - набор блоков, который используется для формирования расчетных схем в текущем активном шаблоне. Создание расчетных моделей с использованием блоков – один из способов разработки расчетных моделей в SimInTech.

Отображение групп кнопок пользователь может изменять по своему усмотрению. Для того, чтобы отобразить или скрыть группы кнопок, необходимо нажатием правой кнопки мыши по области кнопок вызвать выпадающее меню, в котором затем нужно активировать или деактивировать путем установки/снятия галочек видимость нужных пользователю групп кнопок в главном окне (Рисунок 3).

Рисунок 3. Контекстное меню в главном окне SimInTech.

Для отображения палитры блоков в виде дерева необходимо нажать на отдельную иконку «Библиотека блоков» (Рисунок 4).

Рисунок 4. Кнопка отображения палитры блоков в виде дерева.

Рисунок 5. Палитра блоков в виде дерева.

Набор блоков в палитре блоков изменяется в зависимости от выбранного типа расчетной схемы, например, при выборе «Схема теплогидравлическая», отображается набор блоков для реализации теплогидравлических моделей в соответствии с решателем схемы.

Все новые проекты в SimInTech создаются на основе расчетной схемы. Расчетная схема подходит для решения определенного круга инженерных задач, содержит заранее определенный решатель и соответствующие настройки.

В зависимости от установленной конфигурации SimInTech может отображаться разный набор расчетных схем. В базовой версии SimInTech (на дату создания данного руководства) доступны следующие типы схем:

  • Схема модели общего вида.
  • Схема надёжности.
  • Схема теплогидравлическая.
  • Схема TPP.
  • Схема электрическая.
  • Пакет.
  • Пустой проект.

Создание новой расчетной схемы можно осуществить двумя способами:

  1. Выбрать в главном меню пункт «Файл» - «Новый проект» и из выпадающего списка выбрать подходящую расчетную схемы.
  2. Воспользоваться кнопкой «Новый проект» на панели кнопок (данная кнопка находится в группе «Файл», поэтому если она не отображена в основном окне, то необходимо нажатием правой кнопки мыши по главному окну SimInTech вызвать меню настройки видимости групп и активировать для отображения группу кнопок «Файл»), после чего в выпадающем списке выбрать подходящую расчетную схему.

После выполнения одного из вышеуказанных способов на экране появится окно нового проекта.

Для данного окна полностью применим функционал стандартных методов операционной системы при работе с окнами: можно изменять визуальные размеры окна, его расположение на экране, сворачивать и разворачивать окно на весь экран и пр. При сохранении проекта сохраняются и визуальные настройки окна, например, такие, как размеры окна.

При открытии окна, когда уже ранее было открыто несколько окон других проектов, данное окно будет активным для редактирования, остальные же окна автоматически перейдут в пассивный режим. Перевести их в активный режим можно либо нажатием левой кнопки мыши по области окна, либо вызвав данное окно из строки состояния операционной системы, либо в главном окне SimInTech перейти в меню «Окно», в котором выбрать нужное окно проекта.

Окно проекта является типовым, и строение его одинаково для всех расчетных схем, входящих в SimInTech.

Рассмотрим подробнее области данного окна (Рисунок 6):

  • 1 область – меню окна проекта.
  • 2 область – панель инструментов настройки проекта и управления расчетом;
  • 3 область – рабочая область окна проекта.
  • 4 область – строка отображения расчетной информации.

Рисунок 6. Области схемного окна SimInTech.

Меню окна проекта отвечает за основные функции работы со схемой, такие как создание новой схемы, сохранение схемы, открытие ранее созданных схем, вызов базы данных, предоставление доступа к справочным материалам, а также настройку визуального отображения схемы.

Панель кнопок проекта представляет собой интерфейс для настройки и управления расчетной схемой, которые делятся на две группы: «Слои» и «Расчет» (Рисунок 7). Данные группы можно отобразить или скрыть на схемном окне. Для этого можно либо пройти в меню «Вид» - «Панель инструментов» и активировать/деактивировать соответствующие пункты, либо необходимо нажатием правой кнопки мыши по области кнопок вызвать контекстное меню, в котором можно сделать то же самое.

Рисунок 7. Панели кнопок схемного окна SimInTech.

В первой группе содержатся следующие объекты (Рисунок 7):

  • Возврат из субмодели – кнопка перехода выхода из блока «Субмодель» (становится активной, когда пользователь вошел в блок «Субмодель»).
  • Скрипт – кнопка доступа к редактору скрипта проекта.
  • Параметры расчета – кнопка доступа к окну изменения расчетных параметров схемы.
  • Выбор решателя – поле активации и отображения выбранного пользователем решателя.
  • Индикация/Редактирование – кнопка выбора режима отображения схемы.
  • Визуальные слои – кнопка работы с визуальными слоями проекта.
  • Показать значения на линиях связи – кнопка активации отображения значений на линиях связи (присутствует в «Схема модели общего вида» и «Схема электрическая»).

Во второй группе содержатся кнопки управления расчетом (Рисунок 7):

  • Инициализация – инициализирует расчетную схему, но не запускает ее расчет.
  • Пуск – инициализирует расчетную схему и сразу запускает ее расчет.
  • Сделать шаг – расчетная схема делает один расчетный шаг с величиной, заданной пользователем в расчетных параметрах схемы.
  • Пауза – приостанавливает расчет.
  • Стоп – полностью останавливает расчет.
  • Менеджер данных – кнопка вызова менеджера данных проекта.
  • База данных… – кнопка вызова редактора базы данных в случае, если к проекту подключена файл базы данных.

В рабочей области окна проекта при помощи блоков, находящихся в палитре блоков, можно создавать и редактировать ранее созданные расчетные модели, создавать собственные блоки и многое другое.

Для того, чтобы поместить на схемное окно расчетный блок, необходимо:

  1. Выбрать вкладку в Палитре блоков, на которой находится нужный блок. Блоки в Палитре блоков скомпонованы по вкладкам с учетом общих признаков (например, вкладка «Операторы» общетехнической библиотеки блоков содержит блоки, отвечающие за различные математические действия: сложение, вычитание, умножение, деление и пр.).
  2. Нажатием левой кнопки мыши выбрать блок, который необходимо установить в рабочей области окна проекта: как только блок будет выбран, появится его подсветка в Палитре блоков. При появлении курсора мыши в пределах рабочей области, вид курсора мыши изменится: появится выбранный блок, а вместо курсора появится крестообразный указатель места установки для этого блока.
  3. Выбрать место установки блока в рабочей области окна проекта.
  4. Нажатием левой кнопки мыши установить блок в рабочей области окна проекта.

Строка отображения расчетной информации позволяет контролировать ход расчетного процесса, а также позволяет оперативно изменять масштаб отображения на схемном окне (для этого нужно совершить нажатие левой кнопки мыши на поле «Масштаб», после чего перед пользователем появится окно изменения масштаба для схемного окна (Рисунок 8), включать и отключать сетку схемного окна нажатием левой кнопки мыши по полю «Сетка», включать и отключать привязку объектов к сетке нажатием левой кнопки мыши по полю «Привязка».

Рисунок 8. Окно «Масштаб».

При запуске схемы на расчет в этой области также появляется окно сообщений, в котором отображается диагностическая информация по расчетной схеме: ошибки при задании свойств блоков, предупреждения, связанные с работой блоков и пр.

Задание свойств блока осуществляется при помощи окна свойств блока.

Вызов окна свойств можно осуществить тремя способами:

  1. Выделив блок, нажатием правой кнопки мыши вызвать контекстное меню, в котором выбрать пункт «Свойства объекта» (Рисунок 9).

    Рисунок 9. Пункт «Свойства объекта» в контекстном меню блока.

  2. Выделив блок, нажать на панели кнопок кнопку «Свойства» (Рисунок 10).

    Рисунок 10. Главное окно SimInTech с выделенной кнопкой «Свойства».

  3. Совершив двойное нажатие левой кнопкой мыши по выбранному блоку.

После этого на экране появится окно «Свойства» (Рисунок 11).

Рисунок 11. Окно свойств на примере блока «Синусоида».

В окне свойств в зависимости от выбранного блока могут отображаться следующие вкладки:

  • Свойства – расчетные свойства блока, непосредственно влияющие на его расчет – отображается при наличии свойств у блока.
  • Общие – базовые свойства блока, такие как имя, тип, координаты расположения на листе, видимость и другие – отображается постоянно.
  • Порты – список и редактор входных/выходных портов блока – отображается при наличии у блока портов входа и выхода.
  • Визуальные слои – редактор расположения блока на одном или нескольких визуальных слоях – отображается постоянно.

SimInTech имеет собственный встроенный язык программирования, в котором с помощью операторов и функций можно решить, например, такие задачи, как:

  • расчет математических выражений и уравнений;
  • работа над векторами и матрицами;
  • управление отображением графических примитивов;
  • реализация алгоритмов управления для настройки и отладки моделей.

Вызов редактора языка программирования для текущего активного проекта можно осуществить двумя способами:

  1. Нажав на кнопку «Скрипт» на панели кнопок схемного окна (Рисунок 12).

    Рисунок 12. Вызов окна редактора языка программирования проекта с помощью панели кнопок схемного окна.

  2. Нажав на кнопку «Скрипт» в главном окне программы (Рисунок 13).

    Рисунок 13. Вызов окна редактора языка программирования проекта с помощью главного окна программы.

Для окна проекта доступны два режима отображения рабочей области окна проекта:режим редактирования и режим индикации. Каждый из режимов активирует свои инструменты при работе с окном проекта в процессе расчета схемы. Если активен режим редактирования, то в процессе расчета модели можно просматривать параметры блоков, изменять их свойства и пр. Режим индикации переводит окно проекта в режим мнемосхемы, в котором блоки становятся неактивными для редактирования свойств и просмотра параметров, а у части блоков при совершении определенных действий появляются визуальные окна текущего состояния блока и управления им.

Перевод из одного режима в другой осуществляется с помощью кнопки выбора режима отображения «Индикация/Редактирование», расположенной на панели инструментов настройки проекта и управления расчетом. Режим, который на данный момент выбран пользователем для окна проекта, отображается в меню окна проекта (Рисунок 14).

Рисунок 14. Окно проекта с выбранным режимом отображения рабочей области окна.

Создание модели электрической схемы

Библиотеки блоков для расчета электрических процессов

В SimInTech имеются две библиотеки для расчета электрических процессов: «ЭЦ-Динамика» и «ЭЦ-Статика».

При использовании элементов «ЭЦ-Статика» расчет ведется по действующим (среднеквадратическим) значениям параметров режима электрической сети. Реальный синусоидальный сигнал заменяется эквивалентным за период частоты постоянным током равным амплитуде синусоиды деленным на √2. Расчет выполняется в комплексных числах.

Данный подход применим прежде всего для расчета установившихся режимов в цепях с источниками, работающими с одной частотой, что характерно для энергосистем.

Также подразумевается, что токи и напряжения не содержат высших гармоник, а если таковые есть, то используется их среднеквадратическое значение. При использовании этого метода в процессе расчета можно получить только действующие значения токов, напряжений. Апериодические составляющие, которые могут возникать в переходных процессах, определить нельзя.

При использовании элементов «ЭЦ-Динамика» расчет ведется непосредственно по мгновенным значениям параметров сетей переменного тока.

Рисунок 15. Схема «ЭЦ-Статика» и «ЭЦ-Динамика».

В примере (Рисунок 15) схема слева выполнена из элементов «ЭЦ-Статика»: к источнику с действующим значением напряжения 220В последовательно подключены сопротивление и конденсатор – CR-цепь. Расчет выполняется для частоты равной 50 Гц.

Схема справа выполнена из элементов «ЭЦ-Динамика»: также CR-цепь подключена к источнику синусоидального напряжения частотой 50 Гц, действующее напряжение которого 220 В, а амплитуда равна 220 √2 В.

Рисунок 16. Результат расчёта «ЭЦ-Статика» и «ЭЦ-Динамика».

Результат расчета (Рисунок 16) в первом случае – сразу установившееся – действующее значение напряжения – никакого электромагнитного процесса нет. Во втором случае видим реальную осциллограмму переходного процесса с периодической и апериодической составляющей напряжения.

При необходимости вывода графика спектрального анализа сигнала нужно нажать правой кнопкой мыши на нужный график, выбрать пункт «Анализ данных/Спектральный анализ».

«ЭЦ-Статика» позволяет рассчитывать установившиеся и переходные режимы, длительность которых выше периода частоты питающей сети, например, пуски электродвигателей, длительности которых составляют до нескольких секунд, что много больше 0,02 с – периода промышленной частоты. Шаг расчета при этом может достигать 0,02 – 0,1 сек, что позволяет уложиться в режим реального времени даже при сети с большим числом узлов.

«ЭЦ-Динамика» - рассчитывает фактическую осциллограмму процесса. Однако шаг расчета даже для сети промышленной частоты 50 Гц должен быть, как правило, не более 0,001 с. Эта библиотека применяется для исследовательских задач или практических задач, в которых нужно увидеть электромагнитные процессы близкие к реальным.

В данном Руководстве рассматриваются принципы работы с SimInTech на примере создания моделей с использованием библиотеки «ЭЦ-Динамика».

Создание новой электрической схемы

Для создания новой электрической схемы необходимо выполнить следующие действия:

  1. В главном окне SimInTech на панели кнопок выбрать кнопку «Новый проект».
  2. В выпадающем меню выбрать пункт «Схема модели общего вида» (Рисунок 17).

Рисунок 17. Меню создания нового проекта «Схема модели общего вида».

Перед вами появится новое окно проекта «Схема модели общего вида.prt», в котором будет происходить разработка электрической схемы модели (Рисунок 18).

Рисунок 18. Окно проекта для создания расчетных схем из блоков библиотеки «ЭЦ-Динамика».

Сохранить созданный проект с новым именем для облегчения его последующей идентификации в директории. Для этого:

  1. В главном окне войти в меню «Файл → Сохранить проект как...».
  2. В появившемся окне проверить выбор директории сохранения. В данном и последующих упражнениях для работы с проектами будет использоваться директория по умолчанию: C:\Users\<имя пользователя>\Documents\ SimInTech, где <имя пользователя> - имя учётной записи пользователя в операционной системе.
  3. В появившемся окне сохранения проекта в поле «Имя файла» изменить имя проекта на «Схема электрическая 1» (Рисунок 19) и нажать на кнопку «Сохранить».

    Рисунок 19. Сохранение новой электрической схемы.

  4. После того, как сохранение проекта было произведено, необходимо обратить внимание, что заголовок окна проекта изменился в соответствии с заданным при сохранении именем.

Внимание: после сохранения проекта заголовок окна проекта изменился в соответствии с заданным при сохранении именем. Также, SimInTech сохраняет резервные копии файлов с расширением «.prt.1», «.prt.2», «.prt.3» и т.д., которые можно открыть, нажав Главное меню -> Файл -> Открыть старую версию… (Рисунок 20).

Рисунок 20. Раздел «Открыть старую версию...».

Создание модели электрической схемы

Приступим к разработке расчетной модели. Стоит обратить внимание, что в меню остались вкладки, относящиеся к созданию систем управления, электрических схем и др., а, например, библиотеки теплогидравлики были исключены.

Сейчас в палитре блоков перед вами отображаются следующие вкладки библиотек, которые будут необходимы при создании модели:

  • «Автоматика»: Источники; Операторы; Векторные; Функции, Динамические и т.д.;
  • «ЭЦ-Динамика»;
  • «ЭЦ-Статика».

Основные блоки для создания модели электрической схемы, расположенные в вкладке «ЭЦ-Динамика» (Рисунок 21). Данная вкладка содержит базовые блоки, с помощью которых разрабатываются расчетные модели электрических систем.

Рисунок 21. Библиотека расчетных блоков с выбранной вкладкой «ЭЦ-Динамика».

Блоки на вкладках библиотеки могут находиться как отдельно, так и быть скомпонованы в подменю, объединяющие блоки по классовому признаку. Например, на данной вкладке находятся следующие подменю:

  • «Элементы топологии»;
  • «Электротехнические элементы»;
  • «Источники»;
  • «Измерители»;
  • «Силовая электроника»;
  • «Трансформаторы»;
  • «Электрические машины»;
  • «Коммутационные аппараты»;
  • «Элементы управления и обработки сигналов»
  • «Элементы для разработчика».

Расчетная модель, которая будет создана в рамках данного упражнения, состоит из следующих блоков, которые находятся в подменю на вкладке «ЭЦ-Динамика»:

  • 1 блок «Источник напряжения» (подменю «Источники») – с помощью данного блока будет смоделирован источник напряжения постоянного тока.
  • 1 блок «Двигатель постоянного тока» (подменю «Электрические машины») - с помощью данного блока будет смоделирован двигатель постоянного тока.

Помимо блоков библиотеки «ЭЦ-Динамика» потребуется установка блоков общетехнической библиотеки «Автоматика»:

  • 1 блок «Ступенька» (вкладка «Источники») – с помощью данного блока задаётся нагрузка на двигателе.
  • 1 блок «Временной график» (вкладка «Вывод данных») – с помощью данного блока осуществляется вывод рассчитанных значений на график.

Для удобства чтения модели электрической схемы желательно расположить её элементы так, чтобы сама модель повторяла чертёж этой схемы.

В данном упражнении составлять модель от источника питания.

Поместить блок «Источник напряжения» на форму расчетной схемы.

Для этого необходимо выполнить следующие действия:

  1. Нажать левой кнопкой мыши по подменю «Источники», в результате чего появится список блоков, находящихся в данном подменю (Рисунок 22).

    Рисунок 22. Активированное подменю «Источники» со списком входящих в него расчетных блоков.

  2. Нажать левой кнопкой мыши по блоку «Источник напряжения» (Рисунок 23).

    Рисунок 23. Подменю «Источники» - выбор блока «Источник напряжения» в списке блоков.

  3. Перевести курсор мыши на рабочую область проекта. В рабочей области возникнет графическое изображение блока «Источник напряжения», которое будет следовать за указателем мыши.
  4. Выбрать место для установки блока и нажать левой кнопкой мыши, завершая установку блока в рабочей области окна.

После установки блока его можно передвинуть. Для этого необходимо нажать на него левой кнопкой мыши и, удерживая, передвигать.

Аналогичными действиями из подменю «Электрические машины» установить блок «Двигатель постоянного тока» (Рисунок 24).

Рисунок 24. Блоки «Источник напряжения» и «Электрические машины».

Блоки библиотеки «ЭЦ-Динамика» могут иметь порты как для образования электрических связей, так и для образования математических связей. Электрические связи служат для образования расчетной электрической схемы. Математические связи для передачи сигналов управления.

Установить блок «Временной график» из вкладки «Вывод данных» и блок «Ступенька» из вкладки «Источники» на рабочую область проекта.

Двойным нажатием левой кнопки мыши на блок «Источник напряжения» открыть окно «Свойства» и задать значения свойствам согласно рисунку (Рисунок 25).

Рисунок 25. Свойства блока «Источник напряжения».

Блок «Источник напряжения» имеет два порта выхода. После настройки свойств этого блока порт с подписью «1» соответствует положительному выходу источника постоянного напряжения, а порт с подписью «0» – отрицательному.

Аналогичными действиями задать свойства блока «Двигатель постоянного тока» согласно рисунку (Рисунок 26).

Рисунок 26. Свойства блока «Двигатель постоянного тока».

В блоке «Двигатель постоянного тока» порты с подписью «а+» и «а-» являются клеммами якорной обмотки, а порты с подписью «f+» и «f-» являются клеммами обмотки возбуждения. Порт с подписью «Tm» предназначен для задания момента нагрузки двигателя, а порт с подписью «w» выдаёт значение частоты вращения якоря двигателя в радианах за секунду.

Задать свойства блока «Ступенька» согласно рисунку (Рисунок 27).

Рисунок 27. Свойства блока «Ступенька».

Таким образом настройка блока «Ступенька» первые четыре секунды моделирования задаёт режим холостого хода, а после подаёт на порт с подписью «Tm» блока «Двигатель постоянного тока» значение нагрузки равное «0.2».

Собрать схему электроснабжения двигателя согласно рисунку (Рисунок 28).

Электрическая схема собирается путем соединения портов входа и выхода, предназначенных для присоединения электрической связи.

Рисунок 28. Схема электроснабжения электродвигателя.

Нажать на кнопку «Параметры расчёта» и задать параметры согласно рисунку (Рисунок 29).

Рисунок 29. Окно «Параметры проекта».

Запустить проект на расчёт. Двойным нажатием левой кнопки мыши по блоку «Временной график» открыть график расчёта выходных значений. График должен быть аналогичен рисунку (Рисунок 30).

Рисунок 30. График скорости вращения вала двигателя.