Создание схемы алгоритма

Для создания схемы алгоритма (или регулятора) необходимо:

  1. Создать новый проект. Рабочее окно редактирования нового проекта вызывают командой главного меню Файл → Новая схема → Схема модели общего вида или последовательным нажатием левой клавиши «мыши» на значке «Новый проект» главной панели инструментов и «Схема модели общего вида», в соответствии с рисунком (Рисунок 1).

    Рисунок 1. Создание схемы модели общего вида

  2. В рабочем окне с именем «Схема модели общего вида.prt» создать схему алгоритма:
    • из закладки «Источники» палитры блоков главного окна графической оболочки в рабочее окно проекта вставить блоки Входной контакт и Выходной контакт, показано на рисунке 2;

      Рисунок 2. Блоки входного и выходного контактов

    • из любых закладок (источники, операторы, векторные и т.д.) палитры блоков главного окна графической оболочки выбором требуемых функциональных или других по типу блоков в рабочем окне проекта собрать схему алгоритма, показано на рисунке (Рисунок 3).

      Рисунок 3. Схема алгоритма

      Подробное описание состава блоков и их свойств приведено в справочной системе, которая вызывается командой главного меню Справка → Содержание, в соответствии с рисунком (Рисунок 4).

      Рисунок 4. Справочная система

  3. Задать параметры блоков. Окно редактирования свойств блока вызывают двойным нажатием левой кнопки «мыши» по графическому изображению блока в рабочем окне проекта. В качестве примера на рисунке (Рисунок 5) представлено окно редактирования «Свойства : …» свойств блока «Входной сигнал». Имя входного сигнала (переменной) указывают в строке «Имя контакта».

    Рисунок 5. Свойства блока

    В качестве имени сигнала можно использовать как латинские, так и русские названия, при этом система автоматически транслитерирует русские наименования в латинские по следующей таблице:

    Русские символы Латинские символы
    ё yo
    й y
    ц c
    у u
    к k
    е e
    н n
    г g
    ш sh
    щ xh
    з z
    х h
    ъ  
    ф f
    ы y
    в v
    а a
    п p
    р r
    о o
    л l
    д d
    ж j
    э e
    я y
    ч ch
    с s
    м m
    и i
    т t
    ь  
    б b
    ю yu
    Ё YO
    Й Y
    Ц C
    У U
    К K
    Е E
    Н N
    Г G
    Ш SH
    Щ XH
    З Z
    Х H
    Ъ  
    Ф F
    Ы Y
    В V
    А A
    П P
    Р R
    О O
    Л L
    Д D
    Ж J
    Э E
    Я Y
    Ч CH
    С S
    М M
    И I
    Т T
    Ь  
    Б B
    Ю YU
    - _
    . _
    , _
    ; _
    / _
    \ _
    ^ _
    + _
      _
  4. Отредактировать параметры расчета. Окно редактирования параметров расчета вызывают нажатием левой кнопки мыши на кнопку «Параметры расчёта» в рабочем окне проекта, показано на рисунке (Рисунок 6).

    Рисунок 6. Кнопка доступа к параметрам расчета

  5. Задать имя генерируемого исполняемого файла. В окне редактирования параметров расчета вводят значение контрольного параметра «Имя (имена) алгоритма», показано на рисунке (Рисунок 7), имя my_diagram.

    Рисунок 7. Окно параметров расчета

  6. Провести локальное моделирование созданной схемы алгоритма. Под локальным следует понимать моделирование работы расчетной схемы при помощи встроенного ядра автоматики SimInTech без загрузки ПО в прибор. Запуск расчета созданного алгоритма производят нажатием кнопки «Пуск» в главной панели инструментов, показано на рисунке (Рисунок 8), или нажатием клавиши F9.

    Рисунок 8. Кнопка запуска расчета

    В SimInTech разработана система семантического контроля наличия ошибок, которая в строке сообщений рабочего окна проекта указывает на недостатки при определении свойств блоков, соединении блоков между собой и многие другие.

    В качестве примера удалим значение параметра «Коэффициент усиления» инерционно-дифференциального звена с именем DifAperiodika1. На рисунке (Рисунок 9) приведено рабочее окно проекта с расчетной схемой, на которой присутствует указанный блок.

    Рисунок 9. Сообщение об ошибке при запуске

    При запуске расчетной схемы (алгоритма) на счет в строке сообщений высвечивается надпись:

    «(1): Выражение задано не полностью» в объекте DifAperiodika1

    «Параметр элемента: Коэффициенты усиления(k) не может быть вычислен» в объекте DifAperiodika1

    При двойном нажатии левой клавишей «мыши» на имя элемента в строке сообщений в рабочем окне проекта будет подсвечен блок с ошибкой.

  7. Сохранить созданный проект. Нажатием левой клавишей «мыши» на кнопку Сохранить в главной панели инструментов проект сохраняют в файл на диске с расширением .prt, показано на рисунке (Рисунок 10). Режим присваивания уникального имени проекту при сохранении вызывают командой главного меню Файл → Сохранить проект как… или сочетание нажатия клавиш Ctrl + F2.

    Рисунок 10. Кнопка сохранения проекта